[Rubygems-developers] 0.8.1 fresh install error?

Patrick May patrick at hexane.org
Sat Oct 30 23:41:36 EDT 2004


Hello,

Is this a known install error?  I'll try CVS and see if that works for 
me...

Cheers,

Patrick

--------------------
[laputa:~/programming/rubygems-0.8.1] patsplat% sudo ruby install.rb

As of RubyGems 0.8.0, library stubs are no longer needed.
Searching $LOAD_PATH for stubs to optionally delete (may take a 
while)...
...done.
No library stubs found.

   Successfully built RubyGem
   Name: sources
   Version: 0.0.1
   File: sources-0.0.1.gem
/usr/local/lib/ruby/site_ruby/1.8/rubygems/version.rb:123:in `<=>': 
undefined method `to_ints' for nil:NilClass (NoMethodError)
         from 
/usr/local/lib/ruby/site_ruby/1.8/rubygems/specification.rb:474:in `=='
         from 
/usr/local/lib/ruby/site_ruby/1.8/rubygems/specification.rb:474:in 
`to_ruby'
         from 
/usr/local/lib/ruby/site_ruby/1.8/rubygems/specification.rb:470:in 
`each'
         from 
/usr/local/lib/ruby/site_ruby/1.8/rubygems/specification.rb:470:in 
`to_ruby'
         from 
/usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:115:in 
`write_spec'
         from 
/usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:77:in `install'
         from install.rb:144:in `install_rb'
         from install.rb:148
[laputa:~/programming/rubygems-0.8.1] patsplat% ruby --version
ruby 1.8.0 (2003-08-04) [powerpc-darwin]
[laputa:~/programming/rubygems-0.8.1] patsplat% which ruby
/usr/local/bin/ruby
[laputa:~/programming/rubygems-0.8.1] patsplat%



More information about the Rubygems-developers mailing list