[Rubygems-developers] Overriding UI (for Gemini, the Glade Ruby Gems GUI)

Paul Duncan pabs at pablotron.org
Thu Oct 28 17:56:21 EDT 2004


I'm looking for a bit of help from either Rich or Chad on doing one of
the following:

  Overriding the UI object

  or

  Calculating a reverse-dependency map (figuring out all the packages
  that depend on a given gem, so I know what needs to be removed).

What I've got done so far is sitting in CVS; there's a ViewCVS interface
to the repository at the following URL:

  http://cvs.pablotron.org/?m=gemini

And the anonymous CVS line to grab gemini is

# cvs -d :pserver:anonymous at cvs.pablotron.org:/var/lib/cvs login
Enter password: <press enter>
# cvs -d :pserver:anonymous at cvs.pablotron.org:/var/lib/cvs co gemini

You'll need Ruby 1.8, RubyGems, and the libglade2 bindings.

Questions, comments, etc appreciated.

-- 
Paul Duncan <pabs at pablotron.org>        OpenPGP Key ID: 0x82C29562
http://www.pablotron.org/               http://www.paulduncan.org/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://rubyforge.org/pipermail/rubygems-developers/attachments/20041028/6ced206a/attachment.bin


More information about the Rubygems-developers mailing list