[Rubygems-developers] Issues, some Windows related:

Chad Fowler chad at chadfowler.com
Sat Oct 23 16:41:28 EDT 2004

On 23-Oct-04, at 4:30 PM, Austin Ziegler wrote:

> On Sat, 23 Oct 2004 15:24:17 -0400, Chad Fowler <chad at chadfowler.com> 
> wrote:
>> Thanks Austin.  This is a bunch of nice detail that will help for the
>> next release.  I've got to get a compilation environment setup on
>> windows I guess :(
> There's another point, and I'm not sure "whose" fault it is.
> I tried to do:
>     gem install MultipartAlternativeLite latex needle neelix
> ObjectGraph packrat RedCloth Rodo rublog ruby-cache sqlite-ruby swin
> Syndic8-Ruby Technorati-Ruby vruby webgen

I've been thinking about adding this (and `gem install *gem`).   It's 
not implemented now.

> Just like I could do with rpa-base. It didn't work, so I changed it to
> a batch file, like:
>     gem install MultipartAlternativeLite
>     gem install latex
>     ...
>     gem install Technorati-Ruby
>     gem install vruby
>     gem install webgen

I'd love to blame this one on Microsoft ;)  I guess we need to make a 
change in the way gem.cmd is setup.  I think there are different ways 
to call other programs from batch files, but it's been 7 or 8 years 
since I really knew :)

> On running this batch file, *only* the first call to gem (gem.cmd)
> actually ran. I'm not sure you can do anything about this, but it's
> important to know this limitation if it is the case (can gems be run
> from a Windows batch file?).

I guess I'm going to have to setup my Windows PC.


More information about the Rubygems-developers mailing list