[Rubygems-developers] Optparse library

Hugh Sasse Staff Elec Eng hgs at dmu.ac.uk
Wed Oct 6 09:38:35 EDT 2004


On Wed, 6 Oct 2004, Gavin Sinclair wrote:

> There's no optparse except the standard library one, AFAIK.

<quote from="/home/hgs/ruby/optparse-0.12/README.en">
 	optparse OptionParser

Yet Another Option Parser. 
Features: 
* describe option definition with it's handler 
* specify argument format and convert automatically 
* can emit options' summary 
* possible to add options on the fly 
* completion for option/argument

Author:		Nobuyoshi.Nakada
Home Page: 	http://member.nifty.ne.jp/nokada/ruby.html
Download from:	http://member.nifty.ne.jp/nokada/archive/

To Install:

Only one of the programs supplied needs to be installed, optparse.rb.
To do this run:

 	ruby install.rb

and to install some more files:

 	ruby install.rb more

You may need to be root (superuser) to do these.

Otherwise, you can install any other place where you have the permittion 
to write.  In this case, you have to append the directory to RUBYLIB 
environment variable:

 	ruby install.rb --dest=DIRECTORY
 	ruby install.rb dest=DIRECTORY more

Of course, you can use shortened options. Try ((%ruby install.rb help%))
for details.


This file was written in English as README.en by
Hugh Sasse <hgs at dmu.ac.uk>
and translated into japanese using the Excite translator at:

http://www.excite.co.jp/world/

so the Japanese version may be strange!
</quote>

My changes were accepted at the time of 0.8 (or earlier, I can't
remember and it's probably irrelevant).  The web page has gone, and
the place it alleges that it has moved to has also gone.

But I'm gettting these after a fresh ruby install anyway. 
>
> Gavin
>
         Hugh


More information about the Rubygems-developers mailing list