[Rubygems-developers] 0.4.0 bugfix release

Jim Weirich jim at weirichhouse.org
Mon May 31 21:25:57 EDT 2004


Gavin Sinclair wrote:
> Since you're implementing option A as well (multiple version specs in one
> require_gem call), doesn't this meet the requirements?
> 
>   require_gem package, "= 1.*", ">= 1.2"

So does ..

     require_gem package, ">= 1.2", "< 2.0"

So the * isn't required at all.

-- 
-- Jim Weirich    jim at weirichhouse.org     http://onestepback.org
-----------------------------------------------------------------
"Beware of bugs in the above code; I have only proved it correct,
not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)



More information about the Rubygems-developers mailing list