[Rubygems-developers] 0.4.0 bugfix release
gsinclair at soyabean.com.au
Mon May 31 18:08:33 EDT 2004
On Tuesday, June 1, 2004, 6:17:45 AM, Chad wrote:
>> So, I'm proposing two changes ...
>> (A) implement multiple requirements, e.g.
>> require_gem package, ">= 1.2", "< 2.0"
>> All requirements must be true for a package to satisfy the require.
>> (B) Implement a pessimistic greater-than version operator.
>> Suggestions for the operator include "*>", ">>", "<*>"
>> I think both (A) and (B) are useful. (A) is more general and includes
>> the (B) case, but I think you still want (B) from a convenience
>> I have a private implementation of (B) already working and I have
>> started on (A). I can commit these if there is general approval on
>> this list.
> I strongly approve of (A) and mostly approve with (B). My only minor
> objection is that the symbols for the operators don't look intuitive to
> me. But, I can't think of a better idea. I would be in favor of
> releasing both in the next RubyGems release and seeing what the
> community thinks. My guess is that both would be used infrequently and
> that (A) would be used more than (B), but that's not a reason not to
> include them.
> So, my vote is to commit.
What happened to "1.*"?
require_gem package, "1.*", ">= 1.2.7"
is far more intuitive to me than any of those fancy new operators.
I fully approve of the gist of everything else, though (good summary).
More information about the Rubygems-developers