[Rubygems-developers] Another plug for Simon's patch
gsinclair at soyabean.com.au
Wed Mar 31 15:43:36 EST 2004
>> How about a syntax like this ...
>> require_gem 'log4r', "1.*"
>> It would match any version 1.0, 1.1, 188.8.131.52.5, etc. But version 2.0
>> would not match.
> I like that a lot. Much better than the proliferation of <>=....
Yeah, it's good. You should be able to provide multiple version
require_gem 'log4r', '1.*', '> 1.0.5'
That much seems reasonable. Now, stretching it a bit, what if version 1
OR 2 or log4r was OK, but not 3?
require_gem 'log4r', '.*', '> 1.0.5'
More information about the Rubygems-developers