[Rubygems-developers] Try this gem, please

Gavin Sinclair gsinclair at soyabean.com.au
Wed Mar 31 15:14:25 EST 2004


> All,
>
>    I've used Rich's source build code to create a gem for ripper.  It
> works on our Macs.  Can some of you give it a try and see if it works
> for you?  I've got it up at http://www.chadfowler.com/ripper-0.1.0.gem.
>   You'll have to manually download it and install it, of course.
>
> Thanks!
> Chad

It works!  (ruby 1.8.1 (2003-12-25) [i386-cygwin])

Below is the output when I run it, just to draw attention to some things:
 - Local installation worked, but it attempted (and failed)
   remote installation anyway
 - The error produced by remote installation's failure is quite
   unfriendly

Also, running 'gem -i ripper' with your gem in the current directory does
not find and install the file that's right in front of it.

I'll try to sort these issues out.

By the way: gem files are self-installable.  Is that a good idea, now that
'gem --install' does a good job and offers more options?  I'd like gems to
be more data than program.

Cheers,
Gavin

--

$ gem -i ripper-0.1.0.gem
Attempting local installation of 'ripper-0.1.0.gem'
ruby extconf.rb -i ripper-0.1.0.gem
creating Makefile

make
touch parse.y
ruby tools/preproc.rb parse.y > ripper.y
bison -t -oripper.c ripper.y
gperf -p -j1 -i 1 -g -o -t -N rb_reserved_word -k'1,3,$' keywords > lex.c
ruby tools/list-parse-event-ids.rb parse.y | ruby
tools/generate-eventids1.rb > eventids1.c
gcc -g -O2   -I. -I/usr/lib/ruby/1.8/i386-cygwin
-I/usr/lib/ruby/1.8/i386-cygwin -I.   -DRIPPER -c r
ipper.c -oripper.o
gcc -shared -s -Wl,--enable-auto-import,--export-all  -L"/usr/lib" -o
ripper.so ripper.o  -lruby  -l
crypt
ruby tools/list-parse-event-ids.rb -a parse.y > ids1
ruby tools/list-scan-event-ids.rb -a eventids2.c > ids2
ruby tools/generate-ripper_rb.rb ripper.rb.in ids1 ids2 > lib/ripper.rb

make install
install -c -p -m 0755 ripper.so /usr/lib/ruby/gems/1.8/gems/ripper-0.1.0/lib
Successfully installed ripper version 0.1.0
Attempting remote installation of 'ripper-0.1.0.gem'
Error installing gem ripper-0.1.0.gem: Could not find ripper-0.1.0.gem >
0.0.0 in the repository/usr
/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:96:in
`find_latest_valid_package_in_caches'
/usr/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:26:in `install'
/usr/bin/gem:552:in `_install_remote'
/usr/bin/gem:406:in `install'
/usr/bin/gem:114:in `run'
/usr/bin/gem:668





More information about the Rubygems-developers mailing list