[Rubygems-developers] Another plug for Simon's patch

David A. Black dblack at wobblini.net
Wed Mar 31 16:23:49 EST 2004


Hi --

On Wed, 31 Mar 2004, Chad Fowler wrote:

> 
> On 31/3/2004, at 8:06 AM, Mauricio Fernández wrote:
> > I believe
> >  require_gem 'log4r'
> > should be
> >  require_gem 'log4r', ">1.0.5" # implicit < 2.0 and assumes a 
> > versioning
> >                                # policy
> >
> 
> I understand the potential need for multiple relational requirements, 
> but I personally hate the implicit "< 2.0" idea here.  I would be more 
> accepting of the more verbose:
> 
>     require_gem "log4r", "> 1.0.5", "< 2.0.0"

I would too, or maybe:

  require_gem "log4r", "1.0.5 < < 2.0.0"

or something.  Hmmm... a Range?  "1.0.5 ... 2.0.0" or is that too
risky with the dots? :-) In any case, > x by itself doesn't/shouldn't
have any implications beyond > x.


David

-- 
David A. Black
dblack at wobblini.net



More information about the Rubygems-developers mailing list