[Rubygems-developers] IMPORTANT: change in CVS not backward compatible

Richard Kilmer rich at infoether.com
Sun Mar 28 23:08:00 EST 2004

OK, OK, I could not stand it anymore.  The install.rb migrates your 
gems if they are in the old directory structure into the new one.

So, ignore the IMPORTANT message if you gems from CVS :-)


On Mar 28, 2004, at 9:21 PM, Richard Kilmer wrote:

> It used to be that the individual gems were all under the root 
> directory (alongside cache, etc), They are now in the gems 
> subdirectory.  Since this is an alpha, I did not take the time to 
> modify the install.rb to relocate the gems.  You can do that yourself 
> upon install (if you grab CVS) or just remove your entire rubygems 
> directory structure and start anew...up to you.  If you don't move the 
> gem directories though (or just remove the whole gem dir structure), 
> and you install from CVS, your gems 'database' will not be in a happy 
> state :-)

More information about the Rubygems-developers mailing list