[Rubygems-developers] update-dist request from rubytalk

Chad Fowler chad at chadfowler.com
Mon Jun 7 19:04:57 EDT 2004


On 7/6/2004, at 6:14 PM, Gavin Sinclair wrote:

> On Tuesday, June 8, 2004, 2:48:15 AM, Chad wrote:
>
>
>
>> On Mon, 7 Jun 2004, Jim Weirich wrote:
>
>> #
>> # Chad Fowler said:
> # >>
> # >> You're right, now that I look at it.  I guess he didn't 
> understand the
> # >> email he responded to (or he was just restating the desire to 
> have the
> # >> functionality).
>> #
>> # Oops, I did misunderstand.  I saw "--update-dist" in the request and
>> # immediately thought of the dist-upgrade option on apt-get, and then
>> # described the functionality of the apt-get software.
>> #
>> # Which is fortunate, for I think my misunderstood request is pretty 
>> useful
>> # too.
>> #
>
>> Agreed.  And now it's implemented. :)
>
> Small error: the latest version of a gem is installed several times,
> according to the number of higher versions of it there are.  I'll fix
> it at work today.
>
> I'm just wondering about the method name: --update-all or
> --upgrade-all would be a better match in my mind.  --upgrade-dist
> sounds like downloading and installing the latest RubyGems.
>
> Also, it appears in the --help-options output in the wrong place.
> I'll get that today as well.
>

Thanks.  I'm OK with --upgrade-all if you want to change it while 
you're in there.  I agree on the ambiguity of the name (though it would 
make sense to Debian folks).

Chad



More information about the Rubygems-developers mailing list