[Rubygems-developers] update-dist request from rubytalk

Jim Weirich jim at weirichhouse.org
Mon Jun 7 09:17:50 EDT 2004

I'm forwarding this to the gem developer list so that it won't get lost. 
This is an excellent idea.

For those who aren't aware, --update-dist in a Debian distribution will
download and install updates for only those packages that are already

---------------------------- Original Message ----------------------------
Subject: Re: [ANN] RubyGems 0.5.0
From:    "Sascha Ebach" <se at hexatex.de>
Date:    Mon, June 7, 2004 12:41
To:      "ruby-talk ML" <ruby-talk at ruby-lang.org>

Hi Chad,

> Mostly feasible and something some of us has discussed, but we decided
not to spend the time on it.
> If we achieve our goal (inclusion with the Ruby distribution), its being
packaged as a gem itself is not as useful as if we don't achieve our
> Fun idea, though isn't it?
> I forgot to mention that the 'sources' of remote gems are packaged as a
gem and included with RubyGems.   We could upgrade the sources list
remotely without having to reinstall rubygems.   We are also using Ara's
Session library for unit testing, which we have redistributed and
packaged as a gem and install during the rubygems installation.

It would be cool if you could do gem --update-dist or similiar and the 
newest version of rubygems would be installed.

Thanks for rubygems. This is great stuff.


-- Jim Weirich     jim at weirichhouse.org    http://onestepback.org
"Beware of bugs in the above code; I have only proved it correct,
not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)

More information about the Rubygems-developers mailing list