[Rubygems-developers] New Gem format?

Mauricio Fernández batsman.geo at yahoo.com
Sat Jul 31 14:02:42 EDT 2004

On Wed, Jul 28, 2004 at 09:48:49AM -0400, Chad Fowler wrote:
> # I've also found sw. released only as uninstallable gems :-)) ; no
> # CVS, no .tar.gz, only gems that couldn't be installed due to broken,
> # unsatisfiable dependencies.
> #
> Can you give us some examples?

>From the top of my head, kreed. It has the following dependency:

  - !ruby/object:Gem::Dependency 
    name: arrayfields
    version_requirements: !ruby/object:Gem::Version::Requirement 
          - ">"
          - !ruby/object:Gem::Version 
            version: 3.3.0

The latest arrayfields in the gemarchive is arrayfields-3.3.0.gem.

There were a couple more but I can't remember now...

In this specific case, it doesn't really matter cause kreed is early
pre-alpha, but having uninstallable gems is nonetheless funny.

UPDATE: David Naseby has asked me to tell you that Labyrinth should be
removed from the gem archive.

Running Debian GNU/Linux Sid (unstable)
batsman dot geo at yahoo dot com

More information about the Rubygems-developers mailing list