[Rubygems-developers] Re: Re: [ANN] Ruby Installer for Windows 1.8.2-14_RC5 (from Ruby 1.8.2 preview1)

Lyle Johnson lyle.johnson at gmail.com
Thu Jul 22 15:19:59 EDT 2004


On Fri, 23 Jul 2004 01:08:21 +0900, Richard Kilmer <rich at infoether.com> wrote:

> And, we are adding to Gems the ability to utilize the platform attribute
> within the gemspec to select the appropriate binary vs. source gem (or give
> the user the option) if provided.

As long as we're on the subject, are there any plans to include (and
make use of) metadata about the Ruby version for which a binary gem
was built? If I build a binary gem against Ruby 1.8.1 and you try to
use it with a different Ruby version, it's likely not to work.


More information about the Rubygems-developers mailing list