[Rubygems-developers] [Fwd: Re: R: rubygems undefined method'loaded_from=' for nil::NilClass]

Jim Weirich jim at weirichhouse.org
Wed Jul 14 10:24:06 EDT 2004

Chad Fowler said:
> That was definitely a weird one.  Did you ever have him try the alien
> command?  I definitely want to do more work on the diagnostic stuff with
> RubyGems.  Alien, for example, is pretty stupid about gems that are
> compiled from source right now.

All gem commands were failing because one of the gemspec files were
corrupted (failing with a NoMethodError on a nil object).

One question ... Why are the gemspecs in the specification directory
stored as ruby source.  I would have thought that YAML would be a more
appropriate choice in this area.  Is it worth changing?

> Has anyone tried running unit tests with 0.7.0 (the -t option on gem
> installation)?  I can't seem to find any that it thinks have test suites.
> I'm wondering if it's just a problem with my potentially screwed up
> RubyGems installation or if we have a real bug.

I've not played with the unit test option.

-- Jim Weirich     jim at weirichhouse.org    http://onestepback.org
"Beware of bugs in the above code; I have only proved it correct,
not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)

More information about the Rubygems-developers mailing list