[Rubygems-developers] [Fwd: Re: R: rubygems undefined method 'loaded_from=' for nil::NilClass]

Chad Fowler chad at chadfowler.com
Wed Jul 14 09:55:22 EDT 2004


That was definitely a weird one.  Did you ever have him try the alien
command?  I definitely want to do more work on the diagnostic stuff with
RubyGems.  Alien, for example, is pretty stupid about gems that are
compiled from source right now.

Has anyone tried running unit tests with 0.7.0 (the -t option on gem
installation)?  I can't seem to find any that it thinks have test suites.
I'm wondering if it's just a problem with my potentially screwed up
RubyGems installation or if we have a real bug.

Chad

On Wed, 14 Jul 2004, Jim Weirich wrote:

# I've been working with Petrucci Fabio in debugging a problem he had with
# rubygems.  He posted initially on the ruby-talk list and we tracked it
# down to a problem with the installation of the sws gem on his system.
# Somehow, it looks like the gemspec in the specifications directory was
# invalid and attempting to load it returned nil for the gemspec.
#
# Certainly adding more robust handling of reading the gemspec file is
# called for, but I don't understand how his sws gem installation got
# fouled up in the first place. (sws installs fine on my system).
#
# Read the forwarded message for more details.
#
# --
# -- Jim Weirich    jim at weirichhouse.org     http://onestepback.org
# -----------------------------------------------------------------
# "Beware of bugs in the above code; I have only proved it correct,
# not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)
#


More information about the Rubygems-developers mailing list