[Rubygems-developers] [PATCH] New .gem package format

Chad Fowler chad at chadfowler.com
Tue Jul 13 12:49:38 EDT 2004

On Tue, 13 Jul 2004, Chad Fowler wrote:

# Thanks for the patch, Mauricio!
# I tried it out and it seems to build gem files fine.  I'm getting an error
# when trying to install one.  Did you test installation?  I'll do further
# investigation when I get a chance.

It appears that Gavin's most recent patch broke this. Gavin, in
require_gem, you are calling .index on the gem argument.  If the argument
passed in is a Gem::Dependency, it fails.  I'll see if I can scrape
together some time to fix it.  Otherwise, please go ahead when you're next


More information about the Rubygems-developers mailing list