[Rubygems-developers] Modified require_gem

Gavin Sinclair gsinclair at soyabean.com.au
Tue Jul 13 09:42:55 EDT 2004


>From the ChangeLog:

 * lib/rubygems.rb: (#require_gem) added the ability to do
   "require_gem 'rake/packagetask'", for instance, which is a
   shortcut for "require_gem 'rake'; require 'rake/packagetask'".

This is a feature I quite like, and it's really simple.  However, it's
not necessarily well thought through, so I consider it experimental.
It's well commented in the code and easy to remove if it turns out to
be a problem.  I haven't created a unit test yet, but I will as soon as
I've worked out what corner cases to test.  Ideas, anyone?

Cheers,
Gavin



More information about the Rubygems-developers mailing list