[Rubygems-developers] CVS Problem on RubyForge

Jim Weirich jim at weirichhouse.org
Fri Jul 9 10:32:42 EDT 2004

Tom Copeland wrote:
> Hm.  I'm not sure what the problem is.  The lock directories look fine;
> they're all worldwriteable.  But I went ahead and deleted them anyway to
> see if that would do the trick... pls let me know...

Thanks for the fast response, but the problem still persists.  I tried 
committing a change to that file and got ...

$ cvs commit -m 'indented sources'
cvs commit: Examining .
Checking in sources-0.0.1.gemspec;
  <--  sources-0.0.1.gemspec
new revision: 1.2; previous revision: 1.1
cvs [commit aborted]: could not open lock file 
Permission denied

I'm googling the problem but haven't found anything particularly 
helpful.  One case recommended bouncing the CVS server (which might be 
holding lock files), but I'm assuming rubyforge uses cvs from inetd and 
only starts a cvs server on demand.  If cvs is running as a server, 
perhaps this might be appropriate.

-- Jim Weirich    jim at weirichhouse.org     http://onestepback.org
"Beware of bugs in the above code; I have only proved it correct,
not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)

More information about the Rubygems-developers mailing list