[Rubygems-developers] Default answer not honored

Nathaniel Talbott nathaniel at talbott.ws
Mon Aug 23 19:16:34 EDT 2004


Perhaps this is fixed in CVS, but:

   ntalbott at jacob:~/rails$ gem --version
   0.7.0
   ntalbott at jacob:~/rails$ gem install --remote rails
   Attempting remote installation of 'rails'
   Install required dependency activerecord? [Yn]
   ERROR:  While executing gem ... (Gem::DependencyError)
       Required dependency activerecord not installed

I just hit enter at the "Install required dependency..." prompt, and it 
appears that it took that as a no, instead of the indicated yes. 
Entering a 'y' at the prompt worked fine.

Thanks,


Nathaniel
Terralien, Inc.

<:((><
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2369 bytes
Desc: not available
Url : http://rubyforge.org/pipermail/rubygems-developers/attachments/20040823/d80233a3/smime.bin


More information about the Rubygems-developers mailing list