[Rubygems-developers] rake problems today...

Chad Fowler chad at chadfowler.com
Fri Apr 30 15:49:05 EDT 2004


On 30/4/2004, at 10:29 AM, Dick Davies wrote:

>
> Has rake broken for anyone else?
>
> rasputin at lb:gems$ rake
> /data/ruby/bin/rake:8: uninitialized constant RakeApp (NameError)
> rasputin at lb:gems$
>
> Tried a fresh install of rubygems, got rid of the 'ubygems.rb' trick
> I was using, but I still see this.
>
> I've done the following:
>
> Get rid of all the rubygems folders (
>   lib/ruby/site_ruby/ruby*,
>   lib/ruby/site_ruby/ubygems.rb,
>   lib/ruby/gems,
>   bin/rake
> )
> cvs up my sources
> ruby install.rb
> gem -i rake
> copied rake into bin/
> ran 'rake' from the cvs tree, get the RakeApp error... I get the
> same thing in /tmp, so it's not a Rakefile problem....
>
>
> I tried with and without --gen-rdoc, so it wasn't me <g>....
> anyone know of a recent commit that may have done it?
> All I can think of is the stub lib thing....?
>
> -- 

Yes, looks like it was a library stub problem.  I've fixed (with Rich 
and Jim's help) the problem and committed.

Thanks,
Chad



More information about the Rubygems-developers mailing list