[Rubygems-developers] Try this gem, please

Jim Weirich jim at weirichhouse.org
Thu Apr 1 03:28:19 EST 2004

Chad Fowler said:
> On 31/3/2004, at 3:14 PM, Gavin Sinclair wrote:
>> It works!  (ruby 1.8.1 (2003-12-25) [i386-cygwin])
> Thanks, Gavin!  Any FreeBSD or Linux users out there?

Linux here.  The first install failed because bison wasn't installed.  A
quick "apt-get install bison" fixed that.

The second install attempt claimed that it succeeded, but there where some
errors reported in the output log.  No ".so" file was produced, so I
assume it failed in spite of the success message.

there were a bunch of compile errors, but the first error message was that
gperf wasn't found.  So I did a "apt-get install gperf" and tried again.

The third install attempt compiled without errors and produced a ripper.so
file.  I assume it is working, but I don't know how to use ripper (any
quick test I can do?).

This is a Debian distribution, other details ...

   Linux tardis 2.4.19 #8 SMP Tue Apr 8 10:30:30 EDT 2003 i686 GNU/Linux

-- Jim Weirich     jim at weirichhouse.org    http://onestepback.org
"Beware of bugs in the above code; I have only proved it correct,
not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)

More information about the Rubygems-developers mailing list