[Rubygems-developers] Another plug for Simon's patch

Jim Weirich jim at weirichhouse.org
Thu Apr 1 00:39:18 EST 2004

David A. Black said:
> In any case, > x by itself doesn't/shouldn't
> have any implications beyond > x.

How about a syntax like this ...

  require_gem 'log4r', "1.*"

It would match any version 1.0, 1.1,, etc.  But version 2.0
would not match.

-- Jim Weirich     jim at weirichhouse.org    http://onestepback.org
"Beware of bugs in the above code; I have only proved it correct,
not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)

More information about the Rubygems-developers mailing list