Looks like everything now compiles without error.<br><br>But running a test results in this:<br><br>/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in `require__': no such file to load -- gl/GL (LoadError)<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in `require'
<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; from tests/tc_include_gl.rb:23<br><br>And fixing the case and running results in this:<br><br>./gl/gl.so: ./gl/gl.so: undefined symbol: Init_gl - ./gl/gl.so (LoadError)<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in `require'
<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; from tests/tc_include_gl.rb:23<br><br><div><span class="gmail_quote">On 9/2/06, <b class="gmail_sendername">peter mclain</b> &lt;<a href="mailto:peter.mclain@gmail.com">peter.mclain@gmail.com</a>&gt; wrote:</span>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">Hi,<br><br>&gt; Also, I just checked-in changes for the glut extconf.rb.<br><br>&nbsp;&nbsp;I think we can get rid of the 
extconf.rb files...and with that,<br>maybe we move everything in ext/gl, ext/glut and ext/common up into<br>ext, since I think the only thing in each dir is the single .c file<br>(back with swig, it was nice to have separate dirs, since there were
<br>several dir specific files, now that really isn't the case.<br><br>&nbsp;&nbsp;Try out the top level rake and let me know of Linux problems<br><br>--<br>Peter McLain<br><a href="mailto:peter.mclain@gmail.com">peter.mclain@gmail.com
</a><br>_______________________________________________<br>ruby-opengl-devel mailing list<br><a href="mailto:ruby-opengl-devel@rubyforge.org">ruby-opengl-devel@rubyforge.org</a><br><a href="http://rubyforge.org/mailman/listinfo/ruby-opengl-devel">
http://rubyforge.org/mailman/listinfo/ruby-opengl-devel</a><br></blockquote></div><br>