[ruby-opengl-devel] ruby-opengl install problem with missing rake (which isn't missing)

Jan Dvorak jan.dvorak at kraxnet.cz
Sat Jan 31 15:48:07 EST 2009

On Saturday 31 January 2009 19:10:04 Thomas Bjelkeman-Pettersson wrote:
> Hi friends
> When trying to install ruby-opengl, I get an error, which I am not
> sure is an ruby-opengl packaging error or a problem with gem:
> % sudo gem install ruby-opengl
> ERROR:  While executing gem ... (RuntimeError)
>     Error instaling ruby-opengl:
> 	ruby-opengl requires rake > 0.0.0
> % which rake
> /usr/bin/rake
> % rake --version
> rake, version 0.8.1
> Any suggestions would be most welcome.
> My installation is Ubuntu Desktop 8.10, which I am trying to set up to
> use gl_tail for visualizing web traffic with. gl_tail among other
> things require ruby-opengl.

Not sure why it's not finding rake, however ruby-opengl is included in Ubuntu 
repositories under name libopengl-ruby, so unless you need newer version, it 
is simpler if you install that package.


More information about the ruby-opengl-devel mailing list