[ruby-opengl-devel] Patches for MinGW build

Jan Dvorak jan.dvorak at kraxnet.cz
Wed Apr 1 14:43:33 EDT 2009


Chauk-Mean Proum wrote:
> Hi,
>
> I've been working on the support of OpenGL for the wxRuby GUI toolkit
> with the following configuration :
> - ruby-1.9.1-p0
> - MinGW
>
> This has been successful but I had to patch several files :
> - from the mkrf-0.2.3 gem which is used by ruby-opengl
> - from the ruby-opengl-0.60.1 gem itself
>
> For the mkrf patches, I attached them here for your information but I
> will also post them on the corresponding mailing list.
> The ruby-opengl patches do not include GLUT, it is not needed for
> wxRuby and I haven't been able to build FreeGLUT on MinGW.
>
> Thanks for taking into account the relevant patches for ruby-opengl
> and also for maintaining and improving this great package.
>
>   
Thanks for the patches, i've commited them to the repository. I'm
planning to try full mingw build of all my gems sometimes next week so
this comes handy.

> Cheers.
>
> Chauk-Mean.
>   
regards,
Jan



More information about the ruby-opengl-devel mailing list