[ruby-opengl-devel] install problem

Alain Hoang hoanga at alum.rpi.edu
Wed Nov 7 18:47:52 EST 2007

Hello Mitch,

	Please direct questions like this to the ruby-opengl-devel mailing 
list.  Just for note, I'm forwarding this response to the 
ruby-opengl-devel mailing list.

	In regards to your instlal problems.  It seems that you are trying to 
install the pure ruby version of this gem.  Please try the Win32 version 
that should have pre-compiled bindings for Windows.  If you install the 
pure Ruby version it will try to compile the ruby-opengl bindings which 
requires you have the proper development environment installed to 
compile properly.

Mitch Mattek wrote:
> Hey, I can't get the open gl to install on a windows box... it worked fine on my machine, but on this box, I did the one click installer, then ran gem install ruby-opengl
> and got this:
> rake RUBYARCHDIR=c:/ruby/lib/ruby/gems/1.8/gems/ruby-opengl-0.50.0/lib RUBYLIBDIR=c:/ruby/lib/ruby/gems/1.8/gems/ruby-opengl-0.50.0/lib extension
> (in c:/ruby/lib/ruby/gems/1.8/gems/ruby-opengl-0.50.0)
> ruby mkrf_conf.rb
> call rake --nosearch
> (in c:/ruby/lib/ruby/gems/1.8/gems/ruby-opengl-0.50.0/ext/gl)
> cl -nologo  -MD -Zi -O2b2xg- -G6  -DWIN32  -Ic:/ruby/include -Ic:/ruby/lib/ruby/1.8/i386-mswin32 -Ic:/ruby/lib/ruby/site_ruby/1.8 -I. -c gl-1.0-1.1.c
> rake aborted!
> undefined method `exitstatus' for nil:NilClass
> c:/ruby/lib/ruby/gems/1.8/gems/ruby-opengl-0.50.0/ext/gl/rakefile:29
> (See full trace by running task with --trace)
> rake aborted!
> Command failed with status (1): [call rake --nosearch]
> c:/ruby/lib/ruby/gems/1.8/gems/ruby-opengl-0.50.0/rakefile:62
> (See full trace by running task with --trace)

More information about the ruby-opengl-devel mailing list