[ruby-opengl-devel] ruby-opengl gem install problem

Al Hoang hoanga at alum.rpi.edu
Fri Mar 16 12:27:16 EDT 2007


Hi Olivier,

	My apologies for the tardy reply.

On Mar 13, 2007, at 3:35 AM, Olivier Renaud wrote:

>
> Hello,
> I'm using rubygems 0.9.0, built from source. The ruby interpreter  
> I'm using is
> also built from source. The rake gem I have is in version 0.7.1.
>
> Tell me if you want any other info, or if you want me do some tests  
> about
> that.
>


	I've not had time to do a full install of Debian testing but after  
looking at the error message carefully my guess it that this is a  
problem with rubygems 0.9.0.  I was able to reproduce this on an  
Ubuntu box with 0.9.0 gems attempting to install ruby-opengl.
	Can I ask you to upgrade your install of rubygems to 0.9.1 or  
later?  There is a known security issue with 0.9.0 and using it is  
not recommended in general so it might be a good idea to upgrade.  I  
think you can do it within rubygems with 'ruby update --system' to  
upgrade rubygems without having to fetch a tarball / zip from somewhere.

	After you update, I believe ruby-opengl should compile and install  
cleanly.  I'll make sure to update the instructions on the website to  
note this and commit something into the gemspec to require 0.9.1  
version of rubygems or higher.



Alain



More information about the ruby-opengl-devel mailing list