[ruby-opengl-devel] ruby-opengl gem install problem

Olivier Renaud o.renaud at laposte.net
Mon Mar 12 14:35:59 EDT 2007


Le lundi 12 mars 2007 01:04, Al Hoang a écrit :
> Hi Olivier,
>
>
> 	Thank you very much for your report.
>
> On Mar 12, 2007, at 7:01 AM, Olivier Renaud wrote:
> > Hi,
> >
> > /home/barjak > gem install ruby-opengl
>
> [snip]
>
> > rake RUBYARCHDIR=/usr/lib/ruby/gems/1.8/gems/ruby-opengl-0.33.0/lib
> > RUBYLIBDIR=/usr/lib/ruby/gems/1.8/gems/ruby-opengl-0.33.0/lib install
> >
> > (in /usr/lib/ruby/gems/1.8/gems/ruby-opengl-0.33.0)
> >
> > rake aborted!
> >
> > Don't know how to build task 'install'
> >
> >
> > (See full trace by running task with --trace)
>
> 	This is odd.  What version of rubygems are you using?   I had a
> Gentoo using friend test this out with the default Rubygems from
> portage and it definitely did not like Rubygems 0.8.x.  The 0.9.x one
> hasn't given me any issues.  But I would definitely like to get rid
> of this bug as it should 'not' be happening.
>
> > Then I can run some tests files (like examples/plane.rb), but some
> > other fails (like smooth_prev.rb) with this message :
> >
> > /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:33:in
> > `gem_original_require': no such file to load -- ../lib/gl_prev
> > (LoadError)
> >
> > from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:33:in
> > `require'
> >
> > from examples/smooth_prev.rb:1
>
> 	I'm afraid you're hitting a separate issue on this one.  In release
> 0.33.0 some of the examples have bad require paths so are busting.
> I've fixed most of them (except aaindex.rb) in trunk and am
> considering pushing out a new release soon.   I will definitely look
> into merging much of Yoshi's old example code into ruby-opengl as I
> found them really useful when I was playing with his old bindings
> too.  I think lots of examples is really helpful as well.
>
> > Then, I tried to do this :
> >
> > # rake install --trace
> >
> > (in /usr/lib/ruby/gems/1.8/gems/ruby-opengl-0.33.0)
> >
> > rake aborted!
> >
> > Don't know how to build task 'install'
>
> 	There definitely is no install task in rake so I'm curious why it's
> asking to run the 'install' ask.  I'll try to get a Debian testing
> box up and test this out.   How did you install rubygems?   I have
> ruby 1.8.5 on my Ubuntu box which is a custom build from Debian
> testing/unstable so I highly doubt it's Ruby.  And up to a couple of
> days ago had been doing all my testing with Rake 0.7.1 so the rake
> version shouldn't factor in (I hope).
>
> > I haven't used rake yet, so I don't know what goes wrong. I'm using
> > Debian testing, with ruby 1.8.5.
> >
> >
> > Maybe using hoe would make it simpler to build the gem, it looks
> > like a handy tool. I especially like the fact that it takes care of
> > announcing the release on the ruby-talk mailing list. Ruby-opengl
> > is important enough to deserve such announces on the ML.
>
> 	I'll look into it.  THanks
>
> > I've also seen that the doc in the gem file is a bit outdated : the
> > file build_install.txt says : "For now, if you want to install ruby-
> > opengl on your system, you can do so manually (there is no gem, nor
> > even a release, for it yet)."
> >
> > It's kind of confusing :)
>
> 	0.33.0's documentation definitely needed updating.  I've been fixing
> a bit of that in trunk while another developer has been adding more
> functionality to the GL bindings.
>
>
>
> Hope that helps,
> Alain
> p.s. if you could post to the mailing list next time, or even this
> reply I'd really appreciate it!

Hello,
I'm using rubygems 0.9.0, built from source. The ruby interpreter I'm using is 
also built from source. The rake gem I have is in version 0.7.1.

Tell me if you want any other info, or if you want me do some tests about 
that.

-- 
Olivier Renaud


More information about the ruby-opengl-devel mailing list