[ruby-opengl-devel] Fix to get it working on my system:

John Gabriele jmg3000 at gmail.com
Tue Aug 29 15:24:15 EDT 2006


On 8/29/06, John Gabriele <jmg3000 at gmail.com> wrote:
> On 8/29/06, John Gabriele <jmg3000 at gmail.com> wrote:
> > On 8/29/06, minh thu <noteed at gmail.com> wrote:
> > > [snip]
> >
> > > Index: trunk/ext/glut/rakefile
> > > ==============================================
> > > --- trunk/ext/glut/rakefile     (revision 20)
> > > +++ trunk/ext/glut/rakefile     (working copy)
> > > @@ -23,7 +23,7 @@
> > >      # Don't understand why swig doesn't define this...
> > >      swig_args = "-DSWIGMAC"
> > >  else
> > > -    extconf_args = ""
> > > +    extconf_args = "--with-ldflags='-lGL -lGLU -lglut'"
> > >      swig_args = "-I/usr/include"
> > >  end
> > >
> >
> > Yup. Got this one. Thanks,
> > ---John
>
> Hmm... That extra extconf_args string is in ext/glut/rakefile, but not
> in ext/gl/rakefile. I'd expect it would be needed there also, and as
> "--with-ldflags='-lGL -lGLU'"...

Whoops. For that last string I meant: "--with-ldflags='-lGL'"

When we have an ext/glu/rakefile, I'd ~expect~ *that* one would need
to use extconf_args = "--with-ldflags='-lGL -lGLU'".

Lots to read yet! :)

---John


More information about the ruby-opengl-devel mailing list