[ruby-opengl-devel] Re : Fix to get it working on my system:

minh thu noteed at gmail.com
Mon Aug 28 14:30:56 EDT 2006


hi,

Robert,
why do you add -lX11 ? glut already wrap x11 on x11 based machines.

sincerly,
vo minh thu

2006/8/28, Robert Krimen <grin.k1tt3n at gmail.com>:
> Index: ext/glut/rakefile
> ===================================================================
> --- ext/glut/rakefile   (revision 20)
> +++ ext/glut/rakefile   (working copy)
> @@ -23,7 +23,7 @@
>      # Don't understand why swig doesn't define this...
>      swig_args = "-DSWIGMAC"
>  else
> -    extconf_args = ""
> +    extconf_args = "--with-ldflags='-lX11 -lGL -lGLU -lglut'"
>      swig_args = "-I/usr/include"
>  end
>
>


More information about the ruby-opengl-devel mailing list