[ruby-oci8-commit] [387] branches/ruby-oci8-1.0: * Makefile: fix wrong dependencies in Makefile when running

nobody at rubyforge.org nobody at rubyforge.org
Fri Apr 23 08:09:02 EDT 2010


Revision: 387
Author:   kubo
Date:     2010-04-23 08:09:01 -0400 (Fri, 23 Apr 2010)

Log Message:
-----------
* Makefile: fix wrong dependencies in Makefile when running
    'make -jNNN (where NNN >= 2)'
    (contributed by Alyano Alyanos. See bug #28129 on rubyforge.)

Modified Paths:
--------------
    branches/ruby-oci8-1.0/ChangeLog
    branches/ruby-oci8-1.0/Makefile

Modified: branches/ruby-oci8-1.0/ChangeLog
===================================================================
--- branches/ruby-oci8-1.0/ChangeLog	2010-04-23 12:06:00 UTC (rev 386)
+++ branches/ruby-oci8-1.0/ChangeLog	2010-04-23 12:09:01 UTC (rev 387)
@@ -1,3 +1,8 @@
+2010-04-23  KUBO Takehiro  <kubo at jiubao.org>
+	* Makefile: fix wrong dependencies in Makefile when running
+	    'make -jNNN (where NNN >= 2)'
+	    (contributed by Alyano Alyanos. See bug #28129 on rubyforge.)
+
 2009-10-21  KUBO Takehiro  <kubo at jiubao.org>
 	* NEWS: add changes between 1.0.6 and 1.0.7.
 	* VERSION: change version to 1.0.7.

Modified: branches/ruby-oci8-1.0/Makefile
===================================================================
--- branches/ruby-oci8-1.0/Makefile	2010-04-23 12:06:00 UTC (rev 386)
+++ branches/ruby-oci8-1.0/Makefile	2010-04-23 12:09:01 UTC (rev 387)
@@ -5,12 +5,10 @@
 
 all: build
 
-build: config.save setup
-
 config.save: lib/oci8.rb.in
 	$(RUBY) setup.rb config $(CONFIG_OPT)
 
-setup:
+build: config.save
 	$(RUBY) setup.rb setup
 
 check: build




More information about the ruby-oci8-commit mailing list