[ruby-dbi-users] Mysql Driver Load error

Makarand Maslekar makarand.km at gmail.com
Fri Nov 28 01:41:06 EST 2008


Hi ,

I am using the ruby mysql connectivity using the DBI on windows platform. I
am getting the error when i use the dbi to connect to mysql.
The error says
c:/ruby/lib/ruby/gems/1.8/gems/dbi-0.4.0/lib/dbi.rb:286:in `load_driver':
Unable to load driver 'Mysql' (DBI::InterfaceError)
    from c:/ruby/lib/ruby/1.8/monitor.rb:242:in `synchronize'
    from c:/ruby/lib/ruby/gems/1.8/gems/dbi-0.4.0/lib/dbi.rb:236:in
`load_driver'
    from c:/ruby/lib/ruby/gems/1.8/gems/dbi-0.4.0/lib/dbi.rb:154:in
`_get_full_driver'
    from c:/ruby/lib/ruby/gems/1.8/gems/dbi-0.4.0/lib/dbi.rb:139:in
`connect'

So can some one help me or provide me the exact steps to resolve this issue?

regards,
makarand
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ruby-dbi-users/attachments/20081128/28163f87/attachment-0001.html>


More information about the ruby-dbi-users mailing list