[ruby-dbi-users] Oracle vs. OCI8 driver

Erik Hollensbe erik at hollensbe.org
Wed Mar 12 18:29:33 EDT 2008


Hello,

What I've been doing the last few days is attempting to get Oracle working so 
I can test the oracle drivers. Chris Maujean (the oracle guru of the two of 
us) has been strapped for time lately, so he handed it off to me and 
said, "Port it to ruby-oci8". 

FTR, this is the only thing that's holding the 0.2.0 release up, with the 
current constraints on what we're able to maintain.

What I found out where a couple of things unbeknownst to me:

1) OCI8 comes with a DBD that (presumably) is actively maintained. The last 
release was on 11/25/2007.

2) The "Oracle" DBD is supports the Oracle 7 interface on RAA. Since I was 
using 8i when it was "old" about 6-7 years ago, I would be heartily surprised 
if Oracle 7 is still in frequent use. Those who are using the Oracle DBD on 
8i and above would probably be better off using the OCI8 DBD if they aren't.

3) I forgot that oracle is lacking simple things like a boolean type, 
therefore rendering a great deal of the "general" test suite useless without 
a lot of case statements on the dbtype.

So in lieu of all of this, I'm proposing:

1) That we deprecate the Oracle driver, politely asking that those that need 
it maintain it, which is the direction we're heading anyways.

2) We modify the test suite to test against OCI8, outright skipping the types 
testing (but making sure the rest works) until 0.4.0 starts development, 
which is going to have a strong focus on type handling.

Complaints/flames/ideas?

-- 
Erik Hollensbe <erik at hollensbe.org>


More information about the ruby-dbi-users mailing list