[ruby-dbi-users] require 'Date' and require 'dbi' issues.

Scott Comboni scott at zenplex.com
Wed Jun 4 19:22:31 EDT 2008


Hello has anyone seen this.

equire 'dbi'
=> true
 >> require 'Date'
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ 
1.8/Date.rb:238: warning: already initialized constant MONTHNAMES
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ 
1.8/Date.rb:243: warning: already initialized constant DAYNAMES
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ 
1.8/Date.rb:247: warning: already initialized constant ABBR_MONTHNAMES
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ 
1.8/Date.rb:250: warning: already initialized constant ABBR_DAYNAMES
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ 
1.8/Date.rb:302: warning: already initialized constant ITALY
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ 
1.8/Date.rb:306: warning: already initialized constant ENGLAND
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ 
1.8/Date.rb:310: warning: already initialized constant JULIAN
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ 
1.8/Date.rb:314: warning: already initialized constant GREGORIAN
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ 
1.8/Date.rb:316: warning: already initialized constant UNIXEPOCH
=> true



Seems there are some conflicts. Any suggestions?  I was thinking I  
could load up ActiveSupport and use those date functions.

thanks
sc




More information about the ruby-dbi-users mailing list