[rspec-users] Rails 3.2.1 breaks stub ?

David Chelimsky dchelimsky at gmail.com
Sat Jan 28 17:28:36 EST 2012


On Sat, Jan 28, 2012 at 8:14 AM, Larry <info at stupidtuesday.com> wrote:
> I have a bunch of specs that ran fine using rspec-rails-2.8.1 and
> Rails 3.1.3, but when I upgraded to Rails 3.2.1 the following line
> choked for the following reason (which I believe is the same problem
> that occurred with "stub_model"):
>
> Code:
> act.stub(:update_attributes).and_raise(ActiveRecord::StaleObjectError)
>
> Error: ArgumentError: wrong number of arguments (0 for 2)

Please run with the --backtrace flag and post the backtrace so we can
see where that error is coming from.


More information about the rspec-users mailing list