[rspec-users] Rails 3.2.1 breaks stub ?

Larry info at stupidtuesday.com
Sat Jan 28 09:14:29 EST 2012


First things first: Thanks for the GREAT gem and all of the work that
you and others put into this - it is much appreciated!

I read on David Chelimsky's blog that Rails 3.2 broke "stub_model" and
that upgrading to rspec-rails-2.8.1 would fix the problem.

I have a bunch of specs that ran fine using rspec-rails-2.8.1 and
Rails 3.1.3, but when I upgraded to Rails 3.2.1 the following line
choked for the following reason (which I believe is the same problem
that occurred with "stub_model"):


Error: ArgumentError: wrong number of arguments (0 for 2)

Has anyone else seen this? Is there a fix? Am I barking up the wrong


More information about the rspec-users mailing list