[rspec-users] nested route not receiving :id parameter within controller spec

Andrew Timberlake andrew at andrewtimberlake.com
Tue Feb 7 02:06:00 EST 2012


Sorry, too quick to answer.
Next clue is the fact that the RSpec error is ignoring your id attribute. try:
post :share, :id => 42
and see if that gets you past the current error

Andrew 

On Tuesday 07 February 2012 at 7:05 AM, Patrick J. Collins wrote:

> I tried that and got the same result, plus rake routes says:
> 
> share_post POST /posts/:id/share(.:format) {:action=>"share", :controller=>"posts"}
> 
> NOT
> 
> share_post POST /posts/:post_id/share(.:format) {:action=>"share", :controller=>"posts"}
> 
> So I don't see how that can be the case...
> 
> Patrick J. Collins
> http://collinatorstudios.com
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org (mailto:rspec-users at rubyforge.org)
> http://rubyforge.org/mailman/listinfo/rspec-users
> 
> 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20120207/49c4de08/attachment.html>


More information about the rspec-users mailing list