[rspec-users] Error running RSpec on RVM OSX Lion

David Chelimsky dchelimsky at gmail.com
Wed Apr 11 20:54:39 UTC 2012


On Tue, Apr 10, 2012 at 5:28 PM, Ryan Macy <ryan.macy at borderjump.com> wrote:
> /Users/ryanmacy/.rvm/gems/ruby-1.9.2-p318/gems/ffi-1.0.11/lib/ffi/
> library.rb:121:in `block in ffi_lib': Could not open library '/usr/lib/
> liblpcapi_ssl.so': dlopen(/usr/lib/liblpcapi_ssl.so, 5): image not
> found (LoadError)
>        from /Users/ryanmacy/.rvm/gems/ruby-1.9.2-p318/gems/ffi-1.0.11/lib/
> ffi/library.rb:88:in `map'
>        from /Users/ryanmacy/.rvm/gems/ruby-1.9.2-p318/gems/ffi-1.0.11/lib/
> ffi/library.rb:88:in `ffi_lib'
>
>
> I've tried searching around for the liblpcapi_ssl library with no luck.

I'm not familiar with liblpcapi_ssl, but every line in that backtrace
references ffi. I'd recommend submitting an issue to
https://github.com/ffi/ffi/issues or contacting one of the maintainers
(I don't see a mailing list listed in the project README:
https://github.com/ffi/ffi).

HTH,
David


More information about the rspec-users mailing list