[rspec-users] Rspec - gem_original_require': no such file to load -- rhom/rhom_db_adapter

Suresh Babu Madineni tejasuresh at gmail.com
Fri Apr 6 03:43:39 UTC 2012


Hello,

Iam trying to use Rspec to test helper methods in my project.

When i run the rspec command on my file, the following error note is
displayed.

 C:/RhoStudio/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
*`gem_original_require':
no such file to load -- rhom/rhom_db_adapter (LoadError)
*        from
C:/RhoStudio/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
`require'
        from ../MYDIR/MYFILE.rb:1
        from
C:/RhoStudio/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
`gem_original_require'
        from
C:/RhoStudio/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
`require'
        from E:/Work/Rhodes/Demo/app/test/dbconnector_spec.rb:10
        from
C:/RhoStudio/ruby/lib/ruby/gems/1.8/gems/rspec-core-2.9.0/lib/rspec/core/configuration.rb:746:in
`load'
        from
C:/RhoStudio/ruby/lib/ruby/gems/1.8/gems/rspec-core-2.9.0/lib/rspec/core/configuration.rb:746:in
`load_spec_files'
        from
C:/RhoStudio/ruby/lib/ruby/gems/1.8/gems/rspec-core-2.9.0/lib/rspec/core/configuration.rb:746:in
`map'
        from
C:/RhoStudio/ruby/lib/ruby/gems/1.8/gems/rspec-core-2.9.0/lib/rspec/core/configuration.rb:746:in
`load_spec_files'
        from
C:/RhoStudio/ruby/lib/ruby/gems/1.8/gems/rspec-core-2.9.0/lib/rspec/core/command_line.rb:22:in
`run'
        from
C:/RhoStudio/ruby/lib/ruby/gems/1.8/gems/rspec-core-2.9.0/lib/rspec/core/runner.rb:69:in
`run'
        from
C:/RhoStudio/ruby/lib/ruby/gems/1.8/gems/rspec-core-2.9.0/lib/rspec/core/runner.rb:10
        from C:/RhoStudio/ruby/bin/rspec:19

The loading problem is displayed only when the file is called using Rspec.
When i run my project in Rho Studio, it works fine and the file produces
desired results.
Unfortunately, iam not able to test my file as RSpec fails to load the
rhom/rhom_db_adapter

I have installed Rhodes, Rho Studio, Rspec(2.9.0) & Ruby 1.8.7

Is there any specific thing i should take care while using Rhom APIs with
Rspec.
Any pointers, how i can overcome this error scenario?

Thanks,
Suresh.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20120406/ca49b099/attachment.html>


More information about the rspec-users mailing list