[rspec-users] How to remove this deprecation warning

Lenny Marks lenny at aps.org
Thu Sep 1 11:16:47 EDT 2011


On Sep 1, 2011, at 5:03 AM, Jim Morris wrote:

> Hi,
> 
> After upgrading to rails 3.1 and rspec-rails 2.6.1 I get the following deprecation warning, however as far as I can tell I am not defining any examples before it is called.
> 
> I am using the default spec_helper generated with rails g rspec:install so why this warning?
> 
> Thanks
> 
> *****************************************************************
> DEPRECATION WARNING: you are using deprecated behaviour that will
> be removed from RSpec 3.
> 
> You have set some configuration options after an example group has
> already been defined.  In RSpec 3, this will not be allowed.  All
> configuration should happen before the first example group is
> defined.  The configuration is happening at:
> 
>  .../spec/spec_helper.rb:10
> *****************************************************************
> 


https://github.com/rspec/rspec-rails/issues/371





More information about the rspec-users mailing list