[rspec-users] Error running rspec on Debian

Carlos Torres khalebpr at gmail.com
Mon Mar 28 21:04:00 EDT 2011


I'm new to Rails and I was planning on trying out RSpec. When I try to
execute the rspec command on Debian v6.0.1, I get the output below:

k4ru050 at DebianBox:~/Desktop/rails_projects/sample_app/spec$ bundle exec
rspec spec/controllers
/home/k4ru050/.rvm/gems/ruby-1.9.2-p180 at rails3tutorial/gems/rspec-core-2.0.1/lib/rspec/core/configuration.rb:306:in
`load': no such file to load --
/home/k4ru050/Desktop/rails_projects/sample_app/spec/spec/controllers
(LoadError)
from /home/k4ru050/.rvm/gems/ruby-1.9.2-p180 at rails3tutorial/gems/rspec-core-2.0.1/lib/rspec/core/configuration.rb:306:in
`block in load_spec_files'
from /home/k4ru050/.rvm/gems/ruby-1.9.2-p180 at rails3tutorial/gems/rspec-core-2.0.1/lib/rspec/core/configuration.rb:306:in
`map'
from /home/k4ru050/.rvm/gems/ruby-1.9.2-p180 at rails3tutorial/gems/rspec-core-2.0.1/lib/rspec/core/configuration.rb:306:in
`load_spec_files'
from /home/k4ru050/.rvm/gems/ruby-1.9.2-p180 at rails3tutorial/gems/rspec-core-2.0.1/lib/rspec/core/command_line.rb:18:in
`run'
from /home/k4ru050/.rvm/gems/ruby-1.9.2-p180 at rails3tutorial/gems/rspec-core-2.0.1/lib/rspec/core/runner.rb:55:in
`run_in_process'
from /home/k4ru050/.rvm/gems/ruby-1.9.2-p180 at rails3tutorial/gems/rspec-core-2.0.1/lib/rspec/core/runner.rb:46:in
`run'
from /home/k4ru050/.rvm/gems/ruby-1.9.2-p180 at rails3tutorial/gems/rspec-core-2.0.1/lib/rspec/core/runner.rb:10:in
`block in autorun'

The versions I'm using are: Rails v3.0.5, Ruby v1.9.2  installed via rvm.

Any suggestions on how to find a workaround for this issue?

Thanks,

Carlos
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20110328/fa580f52/attachment.html>


More information about the rspec-users mailing list