[rspec-users] rspec1.3.2/rspec-rails1.3.4 and Rake 0.9.1 = lots of deprecation warnings

MattR matt.rogish at gmail.com
Fri Jun 3 13:20:33 EDT 2011

Hi folks,

I've been searching google and I don't think this case has yet been 
identified. I've got an older, Rails 2.3 app that is using rspec 1.3.x. We 
upgraded Rake to 0.9.1, and now I get tons of deprecation warnings on 

WARNING: Global access to Rake DSL methods is deprecated. Please Include 
Rake::DSL into classes and modules which use the Rake DSL methods. 
WARNING: DSL method Spec::Rake::SpecTask#task <spec::Rake::SpecTask%23task>called at lib/tasks/rspec.
rake:28:in `initialize'

I tried adding include Rake::DSL in the class that is monkeypatched, but it 
doesn't work (unknown constant etc.). Any ideas? Thanks!!

  require 'spec/rake/spectask'
rescue MissingSourceFile
  module Spec
    module Rake
      class SpecTask        
# I added it here         
        def initialize(name)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20110603/884d4419/attachment.html>

More information about the rspec-users mailing list