[rspec-users] parse!: invalid option "--autotest"

Sean McCleary seanmcc at gmail.com
Wed Jan 19 16:53:49 EST 2011


I keep getting the error every time I try to run my specs with "bundle
exec rake spec":

/Users/sean/.rvm/gems/ruby-1.9.2-p0/gems/rspec-core-2.4.0/lib/rspec/
core/option_parser.rb:18:in `parse!': invalid option: --autotest
(OptionParser::InvalidOption)
        from /Users/sean/.rvm/gems/ruby-1.9.2-p0/gems/rspec-core-2.4.0/
lib/rspec/core/option_parser.rb:4:in `parse!'
        from /Users/sean/.rvm/gems/ruby-1.9.2-p0/gems/rspec-core-2.4.0/
lib/rspec/core/configuration_options.rb:104:in `options_from'
        from /Users/sean/.rvm/gems/ruby-1.9.2-p0/gems/rspec-core-2.4.0/
lib/rspec/core/configuration_options.rb:100:in `global_options'
        from /Users/sean/.rvm/gems/ruby-1.9.2-p0/gems/rspec-core-2.4.0/
lib/rspec/core/configuration_options.rb:65:in `parse_options'
        from /Users/sean/.rvm/gems/ruby-1.9.2-p0/gems/rspec-core-2.4.0/
lib/rspec/core/runner.rb:41:in `run'
        from /Users/sean/.rvm/gems/ruby-1.9.2-p0/gems/rspec-core-2.4.0/
lib/rspec/core/runner.rb:10:in `block in autorun'

I have tried multiple versions of rspec and I still get this error.

I have tried uninstalling all my rspec and autotest gems and also
cleaning up old versions of the gems.

gem cleanup rspec rspec-core rspec-expectations rspec-mocks rspec-
rails autotest autotest-rails

My specs used to run without this error.  I do not know what changed.


More information about the rspec-users mailing list