[rspec-users] require confusion

Katrina Owen katrina.owen at gmail.com
Wed Jan 19 00:44:02 EST 2011


That sounds suspiciously like something on your system thinks it is
RSpec 1.x whereas something else thinks it's RSpec 2.x.

Have you tried using rvm to manage your rubies? http://rvm.beginrescueend.com/

What do 'gem list' and 'sudo gem list' tell you?

Katrina

On Wed, Jan 19, 2011 at 2:50 AM, Steve H. <lists at ruby-forum.com> wrote:
> I'm on Ubuntu 10.10, and I'm trying to figure out what I'm missing in
> regards to the require statement for RSpec's expectation library.
>
> Any code I see on the web requires rspec like:
> require 'spec/expectations'
>
> but to get it to work I always have to change it to
> require 'rspec/expectations'
>
> More of a curiosity than anything else.
>
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>


More information about the rspec-users mailing list