[rspec-users] after changing text in "it" block -e and -l options not working

David Chelimsky dchelimsky at gmail.com
Wed Jan 5 10:59:29 EST 2011


On Jan 5, 2011, at 1:54 AM, Guru Prasad wrote:

> hi guys !
> I am pretty new to rspec and I am still learning.
> I tried to change the text in "it" block and then run the rspec with -e and -l flag with appropriate values.
> 
> But it dint work.
> 
> What i can think of is rspec must have stored the earlier information which is not updated.

RSpec does not do anything like that between runs.

Are you saying you had a passing example at first, and then you changed it, and then it failed? What was the content of the example (the "it" block) before and after the change?

> 
> here is what i got
> ==================================================================
> C:\work>jruby -S rspec specification\xyz\install_spec.rb -l 105
> Run filtered using {:line_number=>105}
> F
> 
> Failures:
> 
>   1) #POST_OPERATIONS should stop machine
>      Failure/Error: if not $pre_arr.has_key?(k.to_s) then
>      NoMethodError:
>        undefined method `has_key?' for "0":String
>      # ./specification/xyz/install_spec.rb:26:in `get_id'
>      # ./specification/xyz/install_spec.rb:25:in `each'
>      # ./specification/xyz/install_spec.rb:25:in `get_id'
>      # ./specification/xyz/install_spec.rb:60
>      # ./specification/xyz/install_spec.rb:106:in `call'
>      # ./specification/xyz/install_spec.rb:106
>      # :1
> 
> Finished in 4.41 seconds
> 1 example, 1 failure
> =================================================================
> 
> please help !!
> 
> Thanks & Regards
> Guru Prasad
> ~guru
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users



More information about the rspec-users mailing list