[rspec-users] Rspec2 for rails 2.3.8?

Justin Ko jko170 at gmail.com
Fri Feb 25 17:06:54 EST 2011


On Fri, Feb 25, 2011 at 2:30 PM, Radhesh Kamath <lists at ruby-forum.com>wrote:

> Hi experts,
>
> I picked up a copy of the rspec book and wrote some tests in spec/lib
> and spec/models for my Rails 2.3.8 code.
>
> I was using rspec 2.5.1, rspec-core 2.5.0, rspec-expectations 2.5.0 et.
> al.
>
> But I realised that the rspec-rails version I am using is meant for
> Rails3.
>
> Which version of rspec-rails should I use for Rails 2.3.8?
>
> Best,
> Radhesh
>
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>


You would need to use version 1.3.3
https://github.com/dchelimsky/rspec-rails

If I were you I would try to upgrade to Rails 3 because RSpec 2 is really,
really nice. Upgrading to Rails 3 is easy and not bad at all unless you have
some non-upgradable gems, like searchlogic for example, then it might be a
pain.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20110225/5f217208/attachment.html>


More information about the rspec-users mailing list