[rspec-users] RSpec Error - "Invalid Option"

Trenton Scott TTS at rainleader.com
Tue Feb 15 20:43:37 EST 2011


I keep getting an issue when running RSpec with Autotest. My
~/.autotest file looks like this:
==FILE BEGINS==
require 'autotest/growl'
require 'autotest/fsevent'
Autotest.add_hook :initialize do |autotest|
        autotest.add_mapping(/^spec\/requests\/.*_spec\.rb$/) do
        autotest.files_matching(/^spec\/requests\/.*_spec\.rb$/)
        end
end
==FILE ENDS==
Any thoughts on what I'm doing wrong?
==ERROR BEGINS==
bundle exec /Users/TTS/.rvm/rubies/ruby-1.9.2-p136/bin/ruby -S /
Users/
TTS/.rvm/gems/ruby-1.9.2-p136/gems/rspec-core-2.3.1/bin/rspec --tty
'/
Users/TTS/Rails/sample_app/spec/controllers/pages_controller_spec.rb'
'/Users/TTS/Rails/sample_app/spec/controllers/
sessions_controller_spec.rb' '/Users/TTS/Rails/sample_app/spec/
controllers/users_controller_spec.rb' '/Users/TTS/Rails/sample_app/
spec/models/user_spec.rb' '/Users/TTS/Rails/sample_app/spec/requests/
layout_links_spec.rb' '/Users/TTS/Rails/sample_app/spec/requests/
users_spec.rb'
/Users/TTS/.rvm/gems/ruby-1.9.2-p136/gems/rspec-core-2.0.1/lib/rspec/
core/option_parser.rb:18:in `parse!': invalid option: --tty
(OptionParser::InvalidOption)
        from /Users/TTS/.rvm/gems/ruby-1.9.2-p136/gems/rspec-
core-2.0.1/lib/
rspec/core/option_parser.rb:4:in `parse!'
        from /Users/TTS/.rvm/gems/ruby-1.9.2-p136/gems/rspec-
core-2.0.1/lib/
rspec/core/configuration_options.rb:64:in
`parse_command_line_options'
        from /Users/TTS/.rvm/gems/ruby-1.9.2-p136/gems/rspec-
core-2.0.1/lib/
rspec/core/configuration_options.rb:46:in `parse_options'
        from /Users/TTS/.rvm/gems/ruby-1.9.2-p136/gems/rspec-
core-2.0.1/lib/
rspec/core/runner.rb:41:in `run'
        from /Users/TTS/.rvm/gems/ruby-1.9.2-p136/gems/rspec-
core-2.0.1/lib/
rspec/core/runner.rb:10:in `block in autorun'
==ERROR ENDS==


More information about the rspec-users mailing list