[rspec-users] ruby 1.8.6

Rob Aldred Rob.aldred at stardotstar.com
Mon Aug 22 10:35:51 EDT 2011

On 22 Aug 2011, at 14:10, Chuck Remes wrote:

> On Aug 21, 2011, at 9:11 PM, David Chelimsky wrote:
>> Hey all,
>> It's growing increasingly difficult for RSpec to support Ruby 1.8.6 as other libraries that rspec's development environment relies on drop support. Noting that 1.8.7 was released over three years ago (6/1/2008), I'd like to drop support for Ruby 1.8.6 for future versions of RSpec, but I'd like to hear from you before I cut the cord.
>> Please raise your objections now or forever hold your peace.
> All of my legacy projects and new projects are 1.9-only, so there is no objection from me.
> cr

Agree, ditch it.
As you pointed out David, it's 3 years old.
People will have to stick of older versions of rspec if they cannot move from 1.8.6
I'd imagine they are the minority.


More information about the rspec-users mailing list