[rspec-users] Autotest will run features, but not specs

Brennon Bortz brennon at brennonbortz.com
Tue Sep 14 17:41:52 EDT 2010

On 27 Aug 2010, at 15:20, David Chelimsky wrote:

> On Aug 27, 2010, at 8:48 AM, Brennon Bortz wrote:
>> On 27 Aug 2010, at 14:44, David Chelimsky wrote:
>>> On Aug 27, 2010, at 8:37 AM, Brennon Bortz wrote:
>>>> On 27 Aug 2010, at 14:29, Brennon Bortz wrote:
>>>>> On 27 Aug 2010, at 14:06, David Chelimsky wrote:
>>>>>> On Aug 27, 2010, at 6:47 AM, Brennon Bortz wrote:
>>>>>>> Not sure what I must have bumped, but autotest won't run any specs--only features.  No errors are given on startup.  I've taken "export AUTOFEATURE=true" out of my ./bashrc file--now I just get a blank screen when running autotest.  Adding "export RSPEC=true" to .bashrc doesn't change anything either.
>>>>>> 1. Get rid of 'Autotest.add_discovery { "rails" }' from ./autotest/discover.rb.
>>>>>> 2. Add autotest-rails to the Gemfile.
>>>>>> If any of the gems listed in the Gemfile have :path or :git options, you need to run "bundle exec autotest".
>>>>>> HTH,
>>>>>> DavidStrange...that does work, but now autotest seems caught in an infinite loop.  When I run autospec, the specs run, then the features, then the features again...and again...and again...and so on.  If I run autotest as follows: "AUTOFEATURE=false autotest", I don't have the problem.  Any other ideas?
>>>> And now (I haven't touched anything...seriously!), even "AUTOFEATURE=false autotest" gives me an endless loop of spec tests...
>>> (I moved your posts to the bottom so we can read them in order. Please post at the bottom or inline.)
>>> I've seen this happen when files are generated during a spec run. What's in spec/spec.opts and cucumber.yml?
>> No spec.opts file, and just the default cucumber.yml file (I believe):
>> <%
>> rerun = File.file?('rerun.txt') ? IO.read('rerun.txt') : ""
>> rerun_opts = rerun.to_s.strip.empty? ? "--format #{ENV['CUCUMBER_FORMAT'] || 'progress'} features" : "--format #{ENV['CUCUMBER_FORMAT'] || 'pretty'} #{rerun}"
>> std_opts = "--format #{ENV['CUCUMBER_FORMAT'] || 'progress'} --strict --tags ~@wip"
>> %>
>> default: <%= std_opts %> features
>> wip: --tags @wip:3 --wip features
>> rerun: <%= rerun_opts %> --format rerun --out rerun.txt --strict --tags ~@wip
> Unless you're running cucumber with --profile rerun, this shouldn't be a problem.
> Do any of your specs generate files? Also, did you try both "autotest" and "bundle exec autotest" with the same results?

Argh...this problem stopped occurring--thought I wouldn't have to deal with it again.  Same setup as we've already discussed--just a loop of cucumber features.  Specs are run, but only once when a file is changed, and then it's back to the features loop.  I've tried both "autotest" and "bundle exec autotest".  "autotest" gives me the behaviour I've described.  "bundle exec autotest" yields the following error:

<internal:lib/rubygems/custom_require>:29: warning: loading in progress, circular require considered harmful - /Users/brennon/.rvm/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems.rb
	from <internal:lib/rubygems/custom_require>:29:in `require'
	from <internal:lib/rubygems/custom_require>:29:in `require'
	from /Users/brennon/.rvm/gems/ruby-1.9.2-p0 at global/gems/bundler-1.0.0.rc.6/lib/bundler/setup.rb:1:in `<top (required)>'
	from <internal:lib/rubygems/custom_require>:29:in `require'
	from <internal:lib/rubygems/custom_require>:29:in `require'
	from /Users/brennon/.rvm/gems/ruby-1.9.2-p0 at global/gems/bundler-1.0.0.rc.6/lib/bundler/shared_helpers.rb:2:in `<top (required)>'
	from <internal:lib/rubygems/custom_require>:29:in `require'
	from <internal:lib/rubygems/custom_require>:29:in `require'
	from /Users/brennon/.rvm/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems.rb:1136:in `<top (required)>'
	from /Users/brennon/.rvm/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems.rb:968:in `load_plugins'
	from /Users/brennon/.rvm/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems.rb:968:in `each'
	from /Users/brennon/.rvm/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems.rb:976:in `block in load_plugins'
	from /Users/brennon/.rvm/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems.rb:976:in `load'
	from /Users/brennon/.rvm/gems/ruby-1.9.2-p0 at stan/gems/hanna-0.1.12/lib/rubygems_plugin.rb:2:in `<top (required)>'
	from <internal:lib/rubygems/custom_require>:29:in `require'
	from <internal:lib/rubygems/custom_require>:29:in `require'
	from /Users/brennon/.rvm/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems/doc_manager.rb:8:in `<top (required)>'
	from <internal:lib/rubygems/custom_require>:29:in `require'
	from <internal:lib/rubygems/custom_require>:29:in `require'
/Users/brennon/.rvm/gems/ruby-1.9.2-p0 at global/gems/bundler-1.0.0.rc.6/lib/bundler/shared_helpers.rb:84: warning: method redefined; discarding old gem
/Users/brennon/.rvm/gems/ruby-1.9.2-p0 at global/gems/bundler-1.0.0.rc.6/lib/bundler/shared_helpers.rb:81: warning: previous definition of gem was here
/Users/brennon/.rvm/gems/ruby-1.9.2-p0 at global/gems/bundler-1.0.0.rc.6/lib/bundler/shared_helpers.rb:116: warning: method redefined; discarding old from_gems_in
/Users/brennon/.rvm/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems/source_index.rb:75: warning: previous definition of from_gems_in was here
/Users/brennon/.rvm/gems/ruby-1.9.2-p0 at global/gems/bundler-1.0.0.rc.6/lib/bundler/shared_helpers.rb:125: warning: method redefined; discarding old refresh
/Users/brennon/.rvm/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems.rb:728: warning: previous definition of refresh was here
/Users/brennon/.rvm/gems/ruby-1.9.2-p0 at global/gems/bundler-1.0.0.rc.6/lib/bundler/shared_helpers.rb:126: warning: method redefined; discarding old bin_path
/Users/brennon/.rvm/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems.rb:323: warning: previous definition of bin_path was here
/Users/brennon/.rvm/gems/ruby-1.9.2-p0 at stan/gems/autotest-4.3.2/lib/autotest.rb:275: warning: (...) interpreted as grouped expression
loading autotest/cucumber_rails
Error loading Autotest style autotest/cucumber_rails (no such file to load -- autotest/rails). Aborting.

Any ideas?  Thanks!

More information about the rspec-users mailing list